"your device isn't compatible with this version" ... except it is ??? help needed


I have just created my first app, and I have been testing it locally in my mobile device without any problem. Not just that, I have tested it in another mobile (different brand) and it worked fine too.

So, I have build my app, I have uploaded it to Google Play Store and… when we try to download it, we get this message “your device is not compatible with this version”.

This is how my manifest looks like at the moment:

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android" android:versionName="2" android:versionCode="2" package="com.testComp.myFirstApp" android:installLocation="preferExternal">
    <application android:icon="@drawable/app_icon"
        <activity android:name="com.google.unity.GoogleUnityActivity"
                <action android:name="android.intent.action.MAIN" />
                <category android:name="android.intent.category.LAUNCHER" />
                <category android:name="com.google.intent.category.CARDBOARD" />
            <meta-data android:name="unityplayer.UnityActivity" android:value="true" />
        <meta-data android:name="IMMERSIVE_MODE" android:value="true" />
    <!-- Set target sdk version to Lollipop to prevent issues with Marshmallow's runtime permissions. -->
    <uses-sdk android:minSdkVersion="19" android:targetSdkVersion="22" />
    <uses-feature android:glEsVersion="0x00020000" />
    <uses-feature android:name="android.hardware.sensor.accelerometer" android:required="true"/>
    <uses-feature android:name="android.hardware.sensor.gyroscope" android:required="true"/>
    <uses-permission android:name="android.permission.NFC"/>
    <uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE" />
    <uses-permission android:name="android.permission.INTERNET" />

    <!-- VR feature tags. -->
    <uses-feature android:name="android.software.vr.mode" android:required="false"/>
    <uses-feature android:name="android.hardware.vr.high_performance" android:required="false"/>

I have also tried changing the “device filter” (from ARMv7 to FAT) and the “Api compatibility” (from Subset to .NET) in the publishing settings, but it doesn´t look to work any better.

I would really appreciate the experience of whoever has had this problem before. I have spent quite a good amount of hours banging my head against it, but I can´t find what am I doing wrong.


Super unnerving to see that you posted this in 2017, popped up first on google… and there is not one response. If you ever found the answer to this, please share it. My hard earned app won’t download on V30’s.

I’m facing the same issue… Unclear what’s the issue. Some say to clear the Google Play app cache and storage data but it still doesn’t work for me.

I had this same problem and for me the issue was the Minimum API Level. I had the minimum API too high, which means some devices were not able to use the app. In Unity go to: Player Settings > Other Settings > Identification >

Minimum API Level: This should be set to the minimum which for me Android 4.4 ‘KitKat’ (API level 19)

Maximum API Level: This should be set to the maximum according to Google, see link Meet Google Play's target API level requirement  |  Android Developers