Zombie SImple AI Help

Hello!

I am trying to make zombies spawn and then chase the player, where ever the play may move to. At this this moment I am using these scripts.

ZombieSpawner
#pragma strict

	// The object to be spawned 
   var SpawnObject : GameObject; 
   
   // in seconds 
   var SpawnStartDelay : float = 0; 
   var SpawnRate: float = 5.0; 
   
   function Start() 
   {
       InvokeRepeating("Spawn", SpawnStartDelay, SpawnRate); 
   } 
   
   // Spawn the SpawnObject 
   function Spawn() 
   {
       Instantiate(SpawnObject, transform.position, transform.rotation); 
   }

and my ZombieAI
#pragma strict

 var target : Transform; //cant't be bothered to do any commments
 var moveSpeed = 3; 
 var rotationSpeed = 3; 
 var range : float=10f;
 var range2 : float=10f;
 var stop : float=0;
 var myTransform : Transform; 
 function Awake()
 {
     myTransform = transform; 
 }
  
 function Start()
 {
      target = GameObject.FindWithTag("Player").transform; 
  
 }
  
 function Update () {
     //rotate to look at the player
     var distance = Vector3.Distance(myTransform.position, target.position);
     if (distance<=range2 &&  distance>=range){
     myTransform.rotation = Quaternion.Slerp(myTransform.rotation,
     Quaternion.LookRotation(target.position - myTransform.position), rotationSpeed*Time.deltaTime);
     }
  
  
     else if(distance<=range && distance>stop){
  
     //move towards the player
     myTransform.rotation = Quaternion.Slerp(myTransform.rotation,
     Quaternion.LookRotation(target.position - myTransform.position), rotationSpeed*Time.deltaTime);
     myTransform.position += myTransform.forward * moveSpeed * Time.deltaTime;
     }
     else if (distance<=stop) {
     myTransform.rotation = Quaternion.Slerp(myTransform.rotation,
     Quaternion.LookRotation(target.position - myTransform.position), rotationSpeed*Time.deltaTime);
     }
  
  
 }

My problem here is the fact I can’t get the zombie to follow the player. It spawns the zombie just fine then it moves to the players starting position, however when I move the player the zombies continue to only move towards my origin and not give chase. A small fix I did was dragging the player target from the scene into the zombie spawner gameobject while the game is paused and then it worked. But I do not know how get the zombies to chase with the player prefab as the target as it only goes to the origin of the player.

Thank you for your help and hope to hear back soon.

As KdRWaylander mentioned: you should check the players position in every frame. Now you only check it when the Zombie spawns, that’s why the zombie moves to the original point. So simply put target = GameObject.FindWithTag("Player").transform; to the first line of the Update method.