2018.2 text mesh pro. plugin Errors.

After updating from 2018.1.7 to 2018.2. I get these game braking errors from text mesh pro:

two of them are about plugins with the same name. and the rest is:
AppData/Local/Unity/cache/packages/packages.unity.com/com.unity.textmeshpro@1.2.4/Scripts/Runtime/TMPro_Private.cs(3709,45): error CS0121: The call is ambiguous between the following methods or properties: TMPro.TMPro_ExtensionMethods.Compare(this UnityEngine.Color32, UnityEngine.Color32)' and TMPro.TMPro_ExtensionMethods.Compare(this UnityEngine.Color32, UnityEngine.Color32)'.

  1. Delete the old version of TextMesh Pro in the Asset folder
  2. Reopen Project
  3. Window → TextMeshPro → Import TMP essentials
  4. Window → TextMeshPro → Project Files GUID Remapping Tool.
  5. Scan & Save.

This will update the project and fix all missing TMP scripts.

See more info on my blog: makaka.org

Jason the senior programmer I work with says that the error is because Text Mesh Pro is now included as part of the Unity 2018.2 package. So Just delete the downloaded version and the problem will go away.

Thank you. I was struggling to fix this issue and you were right, the latest version does seem to simply include it.

I have downloaded Unity 2018.2 started a new project and im having the same issue i haven’t upgraded an existing project. I cant seem to find an answer on the forums

Ah, thanks. for clarifying. I didn’t follow the five steps, they just helped me to recognize the problem. In 2018.2 Text Mesh Pro is built in. If you follow the 5 steps it has you re-import it. But that means you are loading it again in to your blank file. Try building a new file and not loading text mesh pro at all. then try using it as if you did load it. in the new version, it is there. It is in a different location, but it is there and you don’t need to load it at all. If you have it loaded it causes the errors.

You also don’t need to run the GUID re-mapper. Again, the way I solved the issue in my project was to manually remove the stand alone version of text mesh pro. That was the only think I need to do. It took me a bit in a legacy project to make sure I did it right, but it did work. For new projects, should be simple, create a new project in 2018.2 and then just start working. no steps. Again, I hope this helps. I understand the frustration, I was very frustrated with this as well until I finally found this post and understood the problem. (didn’t use the steps, but the post helped me to understand it was simply included in the new version and the built in version will conflict with any loaded version because of hec03’s the comment)

In unity 2018 I delete the some dependencies over the manifest.json in Pachages folder.
Just I can continue working.

Since this is marked solved without an explanation, I’ll list my fix in case anyone else sees this. I went to Project Settings>Player>Other Settings>Configuration and changed Scripting Runtime Version to .NET 4.x Equivalent, then restarted Unity.

This is the best answer for me in the end , updating the project to use the latest .NET. It’s in the project settings or preferences. Thanks for that Jon Brant

Deleting the TextMeshPro folder only worked up to the next reload of the project. The .NET fix made it permanently disappear

I just re-imported all my assets and it built fine after the error.