Enable cache server via defaults no longer works?

Hi guys, I’m trying to set up a build machine to use our cache server, so I need to be able to point it to our cache server. It’s remote, so I can’t open Unity on it and click the Preferences checkbox, and it’s shared so I can’t do it once and leave it. We used to be able to do:

$ defaults write com.unity3d.UnityEditor4.x "CacheServerEnabled" 1
But that no longer seems to work: "defaults read" shows the setting as enabled, but the cache server is not actually enabled. When I try it locally on my machine, I open Unity and the checkbox is still unchecked.

Is there something else I need to do now, or is this a regression? I’m using 4.5.4f1 right now.

Answering my own question, turns out you need to do this:

$ defaults write com.unity3d.UnityEditor4.x "CacheServerEnabled" -bool "TRUE"

This works. Appears that Unity really wants it as a bool, and doesn’t understand a string “1”, which is the default for defaults.

Interestingly, ‘defaults write 0’ still disables it.

Frustratingly, ‘defaults read’ just emits 1, whether it is a string, and integer, or a bool.