projector shadow unity 3

material affects entire terrain just trying to create a shadow. Unity 3 plz help

I'm not sure exactly what you mean, but I think this is the answer.

When you make a projector, the texture has to be set to clamp instead of repeating. So, select your texture in the project pane, and you should see the import settings. Then, near the top, you will see Repeat mode, change that to clamp and you should be good to go.