Weird and persistent error : Microsoft (R) Visual C# Compiler version 3.5.0-dev-20359-01 (8da8ba0c)

I have a Unity 2020.3.22f1 project that was perfectly working at first. However, this error occured after editing and saving one of my scripts in Visual Studio (with no apparent bug in it):

I don’t give details about my script or the project, because it doesn’t seem to relate to the project itself or what I did, as the error appears now in all my Unity projects! I first tried to delete the script that triggered the bug, then I deleted the whole project. I even uninstalled/reinstalled Unity (different versions), Visual Studio and Unity Hub. But it seems that now I’m stuck with this forever.

Does anyone have a single clue about this? I saw one or two people having the same problem on the web, and with no other solution than formatting the hard drive. As I’m not working on my personal computer, I can’t do that…I mean, there must be a rational explanation to this bug!!

Thanks you very much for your help.

EDIT: I downloaded the latest version of Unity (2021.2.2f1), launched a brand new project, and the error now turned to: “The specified path can’t be found” (rough translation from french), without more precision…still no idea what it means.

Ok, I found a solution from here:

I don’t know how it’s related, but it is suggested that the error can be triggered by uninstalling Anaconda and Python (which I happened to do recently), which leads to remaining artifacts in the Windows registry. I then deleted the following item in the Windows registry:


and restarted Unity. Now it works!