Asset Script not working

So I’m trying to create a maze and I wanted to use the FPS controller that comes with the unity standard assets. However, it’s not working. It’s saying,

“The associated script can not be loaded. Please fix any compile errors and assign a valid script.”

I’ve tried deleting the script and letting the program reconstruct it (this seemed to work for some people), I’ve also tried backing up the entire asset, deleting it from the program files, then putting it back in, and even deleting and re-downloading the entire asset and even unity itself. Non of this has worked.

If anyone has an idea on how to fix this please let me know.

Have you try deleting standard assets and redownloading them from the asset store?

Yes I have. That also didn’t work. Iv’e also tried installing different versions of unity and that also didn’t work.

Check your console. Any compilation error (in any code) may prevent you from being able to use any scripts. Your console must contains these errors (they won’t disappear even if you clear the console). Fix those, so the compilation may complete successfully and you will be able to load the script.