First Person controller Mouse Look isn't working

I know that this has been asked before, but it was not answered to my satisfaction there. And the thread is now two years old.
I am teaching a class in Unity and have used the FP Controller many times. But today I opened a new project, created a simple terrain, a FPC and ran it. Mouse look did not work! I had not altered it in any way. I shut down Unity and relaunched it, same result. Can anyone give me some insight as to why this is happening? It didn’t happen to any of my students.

Very frustrated.

Ok, so, first of all, is your mouse working? second of all, did you try reimporting the character controller package? third, is your unity up to date? fourth, have you looked in your edit → project settings → input folder? all these may be the problem it’s not working. You may also consider creating a new project and retrying it.

Ok, yes my mouse is working.
Yes, I tried re-importing
Unity is probably not up to date, because the lab techs have not been on the ball over the summer, but it is the same version that my students were using successfully.
I will look at the project settings, I had not looked at that.
I will try making a new project.

But that doesn’t answer the question as to why this would happen? Why would my project settings be different by default than my students?

Thanks for the quick response!

Today I did try the edit-> project settings → input folder (?) idea. I think. I went to edit-> project settings → input, and that opened an input panel. I’m guessing that is what you are speaking of. Looking at that I couldn’t find anything amiss. What specifically should I be looking for? I check the MouseX and MouseY and they were both linked to Mouse Movement as I recall. I’m a bit at a loss.

Thanks in advance.

Hey go to my youtube channel and click on my video on unity tutorial. Then in my description box it will have my site web address and click on that and open it and in the site click on Script and download my unity package :slight_smile: my youtube Channel is :

http://www.youtube.com/user/narutoisgreat1234?feature=mhee

Alright, so I think your mouse settings are fine. Have you tried reimporting the Character Controller package? If it still doesn’t work after reimporting the first person controller, the FPC may be corrupted and you may want to try finding a copy of the character controller package that isn’t corrupted on the web. The other thing to do, which I would highly recommend, is borrow one of your student’s computers and analyze their project and your project carefully to see if there is anything different about your mouse look parameters-
I hope this helps you! :slight_smile:

Hi
Sorry to bring this thread up again, but i have the same problem.
I found the solution is to hide mouse cursor!
When i add Screen.showCursor to fpswalker script, then mouse-look works.
Although sometimes it flickers, but after build and run(webplayer i used), it works perfect.
But the main question of Why this would be happend is still remain mysterious, i think :slight_smile:

I had the same problem, but it seems to be by design.

In addition to adding Component/Character/FPS Input Controller, try also adding Component/Camera/Mouse Look to your Main Camera.

Adding FPS Input Controller results in three components being added (Character Controller, Character Motor, and FPS Input Controller). The later two are scripts, but neither script seems to try and use mouse input (i.e. Input.GetAxis(“Mouse X”), Input.GetAxis(“Mouse Y”))

The Mouse Look script does read the mouse input and apply it to the camera.

I had this problem after importing some assets, which seemed to change the InputManager so that Mouse X and Mouse Y were no longer set up. Since I wanted the InputManager settings to be the defaults, I needed to reset it. So, I solved the issue by opening the InputManager tab, from the Edit/Project Settings/Input, and then I selected Reset from the drop down menu that appears if you click the gear with the arrow below it in the InputManager tab.

This happened to me a couple of times. With the main character selected, check the Mouse Look script in the Inspector. For some reason, my Y numbers were garbage. These settings worked for me:

Sensitivity Y: 15
Minimum Y: -90
Maximum Y: 90

I have the illusion of the same issue, however it was caused by trying to work over a remote desktop session. I left the session and visited the physical computer and the mouse look feature worked flawlessly.

I just overcame this problem by reading one helpful comment.
My learning project was using iOS build, and I am using FBC Controller without changing anything, thus my mouse stop working!
The solution, make the suitable change for inputs if you want to use ios build
or make sure you are using the PC build

The helpful comment :
https://forum.unity.com/threads/first-person-controller-not-working-in-editor-when-switched-to-ios-build-mode.529789/