Github not working with unity

Hey all, I’ve been trying to make github work with unity and but it’s not and I can’t seem to find answers anywhere, so I’ve come to you all for help. Here’s the problem:
I’ve set up a sample 2d scene in unity with a background sprite, a player sprite and a character controller script. It’s all set up properly in the scene view and works as intended. Now when I commit these changes and push to origin with the git desktop client, and the person I’m collaborating with receives it, they receive the assets (both sprites and the character controller script) but the scene is empty and there are no objects in the hierarchy.
We think it has something to do with the gitignore file ignoring more than it should but we’re not sure. We’re using the basic Unity gitignore that gitub provides on creating a new repository.
Here’s the link to the gitignore being used: gitignore/Unity.gitignore at main · github/gitignore · GitHub
Any ideas what could be going wrong?
Note: My teammate also sent me a sample project on unity and it worked as intended on my pc. The only difference between our projects was that her gitignore wasn’t placed in the root directory and thus wasn’t ignoring anything. This reinforces my theory about the gitignore not working properly.

There are plenty of guides on how to get unity to work with git:

The main two problems are serialisation of projects and large file storage for assets. Either way both are explained in the links below.

Update: I’m so sorry for wasting your time guys, it was a stupid mistake. Unity was not automatically loading the scene I had worked on so she had to manually load it. It was so unexpected that we didn’t even think to look there. Thank you all for your prompt responses and patience.

Sorry im dumb, how did you laod the scene on her computer or did you make it to load automaticaly ? Can you please write the way you solved it ? Thanks