How can I get Unity to work on win7?

I have a dell vostro 3550 with intel i5 2,3Ghz, 8 GB Ram and win7 pro 64 Bit.
I tried to install unity 5.4.2f2 (64-bit) as well as the 32-bit version.
Everytime I start the program it freezes after 2-3 clicks. When I minimize and maximize the window the view updates and I can see my last actions. Obviously I cant work like this.
I have already tried to set the performance settings on the Catalyst Control Center from high performance to energy saving like @darkshines said. It doesn’t work.

I have also tried to deactivate DEP in the system settings. It is still not working.
Has anybody a solution to this?

Thank you!

Try installing the latest .NET Framework linked and start unity after its installed tell me if this worked.

May not be the source of the problem for you; but I had this problem as well at first. The issue came from my GPU having issues rendering Unity after a few updates. I figured this out when I replaced my GPU.

You should try 32 bit unity version