No option of 2D Vector Composite in Input System 1.0.0?

I'm adding the new input system to an existing game, but when adding the input actions through the editor I'm not getting an option of 2D Vector Composite? I am getting 1D Axis Composite, and if I select this I can set positive and negative bindings and so forth, but I simply want to add a WASD action, and it's not letting me.
I'm running 2019.3.13f1 with input system 1.0.0 (no preview).
I installed via package manager, set new input in project settings and rebooted.
I created a settings asset (with all left as default). I also added Gamepad, Keyboard and Mouse to supported Devices (though I have tried deleting these and it made no difference).
I then added an input actions asset and created an action map with a single action - Movement.
Expanding the drop down shows , but trying to set the Path under Bindings shows nothing, just Usages.
Attempting to add a new binding (under Movement) gives me four options, New Binding, 1D Axis, and Button with one or two Modifiers - no 2D Vector.
I have uninstalled and reinstalled, rebooting between steps, and am now at a loss as to what to try next

Any Ideas greatly appreciated

Danny

6 Likes

Hi, I had the same problem earlier today and, in case you still need a fix for this (even though it’s been a month), I found the solution: I’m leaving this answer here for anyone who needs it.
The changeling for preview 0.9.3 says “When adding a composite, only ones compatible with the value type of the current action are shown. This will, for example, no longer display a 2D Vector composite as an option on a floating-point button action”.
To show the 2D vector composite just change the action type to “value” and the control type to “Vector2”. Now the 2D vector composite option will appear :slight_smile:

166 Likes

Thank you, very helpful!

4 Likes

I dont have the option at all, how do I get the option?

1 Like

This worked for me thank you

not very clear at all. took me a while

as itspeetah saiz

  • where it saiz 1D axis (blue), goto the action above it (green)
  • on action type to the right, change button to value & then composite type to 2D vector
7 Likes

wow I had this problem too. thanks

2 Likes

DUDE THANKS SO MUCH
this helped a lot, though it shows up as “Add up/down/left/right composite” instead of “2d vector composite”

1 Like

yeah

I dont get it im new I dont know what chnage the action type to value

Thank you very much helped a lot

thanks

Thanks a lot…!

Thanks a lot it works

thanks

Thank you so much. You saved a life

Thanks a lot :slight_smile:

Thanks a lot!

That did not work for me now its only add up/down/left/right composet

For those who use Input System 1.3.0
Add 2D Vector composite has been replaced with Add Up/Down/Left/Right Composite option
That’s the same thing

You need to set Action Properties (green) to Value and Vector 2
After that, the Add Up/Down/Left/Right Composite option should appear

If you need 3D Vector Composite, same thing
Just change Vector 2 to Vector 3 in Action Properties and the option should appear

10 Likes