Read only animations from Mixamo

I’ve imported some animations from Mixamo, but I need to modify some of them. They’re all read only though, so I can’t adjust the animation curves. I’ve read plenty of similar posts that say all you need to do to fix this is duplicate the animation and it should no longer be read only. I’ve done this, but the new duplicate animation is still read only. I made sure to apply the new animation to the animator controller, I also tried making a new controller with only the new duplicate animation to make sure I was looking at the new animation.

Are there any other ways to fix this?

Thanks

So I’ve found a solution, though it’s not ideal.

I was able to fix it by making a brand new animation, selecting all the keyframes in the read only animation, and then just copy pasting them over to the new one. Not sure why I didn’t think of that sooner, but hopefully this will be useful to someone else. I will say it takes a long time for Unity to paste all of the copied keyframes. I actually thought Unity had frozen, but it did work. Luckily I only need to do this for a few animations, otherwise this wouldn’t be very viable.

An easier way of doing this is expanding the model from your project view so you can see all the assets that were imported, and then select the read-only animation, press ctrl+D (duplicate) and it will make a separate animation asset (to save space you can uncheck “import animation” from the model)