Reload Assemblies making enterplaymode take long

I’ve seen others saying that clicking the play button takes them only a second or two to get into play mode. For me it takes around 7-9 seconds every time regardless of if I do the switching build target trick (to reload the targeted platform) or click play several times consecutively.

Thus, I tried profiling the editor a few times to try and find where my issues may arise. Then this got logged,

ReloadAssemblies is taking more than 4 seconds by itself. Is it even normal for ReloadAssemblies to trigger every single time I press play? If so, is it avoidable?

I’ve seen this, LockReloadAssemblies which I haven’t tried as it doesn’t seem like something I should use to solve this (though I’ll try it). Has anyone else had this issue or maybe know of something I can try?

Processor: Intel Core i7-4700MQ 2.40Ghz (3.20 Ghz when it’s doing any decent lifting)

Memory: 16GB

Graphics Card: Intel Graphics 4600 and Nvidia GTX 765M (Default)

I’ve got this problem as well, but I don’t know what to do…

profile your editor, it is often caused by “reaload assemblies”'s GC.

see also:

Same problem here

Switched to Unity 2021 from 2019 and suddenly got this problem as well. Never had this before. What’s going on?