Unity 2017 not giving option for latest target API level 26 or higher.

I have 2 unity editor installed, Unity 2018.1.4f1 and Unity 2017.3.0f3. Both are assigned to same SDK and JDK. When I had installed Unity 2018 it had updated SDK to latest version. Now only Unity 2018 gives me options for API level 26 and 27 for android. But unity 2017, which is also assigned same SDK and JDK do not gives me API level higher than 25.

I have projects compatible only to Unit 2017, which are needed to be updated to API level 26 or higher enforced by google.

Use “Android Studio” to install the needed SDK / API level

(for example "Android 8.0 (Oreo) / API Level 26)

and set in Unity

“Automatic (highest INSTALLED)” as “Target APLI Level”.

This will take the HIGHEST installed SDK …

Note:

If you want to use API Level 26, but you have already higher SDKs installed

(like “Android 8.1 / API Level 27” or “Android 9.0 (Pie) / API Level 28”)

then just UNinstall the needed/higher SDKs!

I have the same question. After uploading a new version of the game and lose and recover the keystore i got the same problem, basically in my unity 2017.1.0f3 that wors magnifically, i don’t got the option to choose the API level 26 . In google play console appear the message ‘Actualmente, el nivel de la API de destino de tu aplicación es el 25 y debe ser al menos el 26 para garantizar que se compile con la API más reciente,’.

How to upload unity and target the API to 26?

You can check PlayerSettings \ Publish Settings \ Custom Gradle Template to use Custom Gradle file to set API manually. For more information, look at Custom Gradle Template.