UnityVCS - The ignore.conf is being... ignored!

I’ve been using PlasticSCM for a number of years, and recently moved to UnityVCS. As such, I have a working knowledge of source control, and am familiar with how to structure and manage projects. However…

Since moving to UnityVCS, I’ve encountered some unexpected behavior with the ignore.conf, which I’ve configured for dozens of projects in the past (but with PlasticSCM). Specifically, what I’m seeing is that the directories I specify in ignore.conf are not being excluded from source control, when they really should be.

Here’s an example…

** I create a test repo called “TEST” **

  1. I create a directory called “Windows”, which contains files.
  2. I commit everything.
  3. I add an ignore.conf.
  4. In the ignore.conf, I add a single line: /Windows
  5. I commit the ignore.conf to source control.

After doing the steps listed, if any additional files are added to /Content, or changed in it, then there should be NO entries in the Pending Changes section-- because the ignore.conf SHOULD be excluding them.

Instead, I still see that UnityVCS is tracking files that were modified in /Content.

Why would that be? What’s the nuclear option here for ensuring that UnityVCS will ALWAYS honor the entries in the ignore.conf?

Hi,

The ignore.conf file can only ignore “Private” files, that is, the files that are not already in version control.

If you want to hide changes made to file in version control, you have to use the hidden_changes.conf file.

Sébastien