Why is Unity skipping Xcode 6.4 support?

The release notes for the latest 4.6.7 and 5.1.2 releases both indicate…
iOS: Added support for Xcode 6.3.2 and Xcode 7 beta.
I’m using the latest Xcode that has actually been released (6.4). Why can’t we build and run from Unity to Xcode 6.4?

I was able to follow this video and then set my build target to 8.1 to get around this as I am on 6.4 also.