[2022.3.1f1 LTS][Input System 1.6.1] UI bug and warning when opening any binding's path dropdown

It happens when I open the “path” dropdown in order to choose a key to bind to an action.

image

The following warning is shown by the console:

Unable to find style ‘ToolbarSearchTextField’ in skin ‘DarkSkin’ Used

  • The bug takes place in at least two versions of the editor: 2022.3.1f1 and 2023.3.0f1.
  • I’ve tried at least two versions of the Input System package: 1.5.1 and 1.6.1.
  • I’ve also tried changing the skin (from “dark” to “light”), however all it does is give me the same error message, but saying ‘LightSkin’ instead.

I wasn’t able to find a combination of editor, package and skin versions that didn’t result in the same bug.

Is it possible for me to fix that on my end?

Same issue with 2022.3.3f1 and InputSystem 1.6.1.

Edit:
I’ve able to select the elements clicking in the right edge of the option. The error still happening and I cant see the search bar.

Same issue with 2022.3.4f1 and Inputsystem 1.6.1

Unable to find style 'ToolbarSeachTextField' in skin 'DarkSkin' Used
UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)

Hello,

Would you kindly please report this issue via the Bug Reporter tool?
https://unity.com/releases/editor/qa/bug-reporting
Please make sure to write the exact steps needed to be taken so that the reproduction would be visually seen. Also make sure to attach a reproduction project and any visual material so that when testing our CQA team can verify that they got the same results. If you can, please use this template:

How to reproduce:

  1. Open the attached project
  2. Do this
  3. Do that
  4. Select this
  5. Observe that

Expected result: Something is visible, something is printed or something happens
Actual result: The opposite of what I expect happens

Reproducible with: Editor version I am using (e.g: 2021.3.xf1)

Reproduced on: The OS I am on (e.g: Windows 11, macOS Ventura 13.1 (Intel/Silicon))

I believe a breaking change has been introduced in 2021.3.28. Specifically that minor version!
Previous string was:
ToolbarSeachTextField
However ‘search’ is now spelt correctly:
ToolbarSearchTextField

There was a typo fix with the GUIStyle string in the Unity version 2021.3.28 and later meaning the anything that used this style would now resolve to null and likely cause a render issue.

Of course this was not documented by Unity in their release notes and probably should not have been part of a minor update on Unity’s side.

I spent quite a but of time tracking down the specific Unity minor version to which the ‘type fix’ was introduced.

Unity 2022.3.12f1 Still there. Anybody have a way to fix it?
image