Admob banner ads not showing up after building but test ads worked.

while I was making the game I used the Admob test IDs and when I built the game and tested it on my phone everything worked fine, I would get a banner ad saying, this is a admob test ad. Once I finished making the game, all I did was replace the AppID and unitID with the real ones that were in my admob account but when I published the game today I saw that no banner ads show. Any ideas why it is not working? Using Google Mobile Ads Unity Plugin v3.14.0. The official google plugin.

private string appId = "ca-app-pub-xxxxxxxxx";
private BannerView bannerView;

private void Start()
{
    MobileAds.Initialize(appId);
}

public void RequestBanner() {

    string adUnitId = "ca-app-pub-xxxxxxxxxx";

    bannerView = new BannerView(adUnitId, AdSize.Banner, AdPosition.Bottom);
    bannerView.OnAdLoaded += DisplayBanner;
    AdRequest request = new AdRequest.Builder().Build();
    bannerView.LoadAd(request);

}

private void DisplayBanner(object sender, EventArgs args) {
    bannerView.Show();
}


https://play.google.com/store/apps/details?id=com.AcedStudios.LightNinjaRunner , that is the game as evident that there is no banner ads

Make sure you have everything filled out under the payment section of your admob dashboard.

check the appID in your manifest file, and make sure it matches with your appID.

I have the same problem too!! No Banner and rewarded ads are showing despite that it worked when I tested the game on Unity Engine. I added my AppID in Assets/Google Mobile Ads/Settings and I intialized the AppID in the Admanager script but still it won’t get to work!!