Bugs / Performance URP project from 2020.1 to 2020.2 causes RenderThread to go from 1ms to 10ms

  • SRP batcher does not seem to work anymore. (HybridRendererV2) When turning it on none of my meshes get rendered anymore.
  • I have noticed worse performance when upgrading from 2020.1 to 2020.2 I noticed a lot of people have peformance issues but most of them are about the CPU usage. In my case i noticed the GPU (render thread) got from about 1ms to about 10ms - 13ms.

Anyone else had similar issues?

3 Likes

Yes Iā€™m having these performance issues too
seems like is a common problem

Phew and I thought I was the only one. I have both. :slight_smile:

Same problem with the SRP Batcher.

Which versions are you all using, anecdotally with 2020.2.0f1 & urp 10.2.2 I don't get these issues, srp batcher must be used otherwise my project doesn't render correctly.

I am using 2020.2.1f with URP 10.2.2 ShaderGraph 10.2.2 (no idea if this is relevant) Also i use the Unity Animation preview package. With SRP batcher nothing gets rendered. Render thread ms is all over the place.

Does it happen in the build or only in the Editor? I have a similar issue in the Editor. I tried profiling and I found that GFX.WaitForPresent is responsible. According to the comments here it seems that render thread is waiting for the GPU. I did some more tests and it seems that it is only happening when materials in my scene are using too many too big textures. It is easy to reproduce with just few PBR materials using 4K textures. Funnily enough compressing them with ASTC seems to help a bit
When I build the project with those textures and I run it on an iPhone XR everything seems to be running smoothly.

I am using 2 texture atlasses 4096x4096 pixels they worked fine in 2020.1.xf

Same issue in the build, performance is less, but i suspect most of it is because SRP batcher is not being used anymore because it does not render meshes atm.

Experiencing similar issues. Render thread in builds take 15ms longer than in editor