Cannot install unity editor from unity hub

I download the editor from Unity Hub but the installation fails every time.

When I try to reinstall by locating the editor through the hub it showed "this version of Unity is already on the list", so I cannot reinstall the same version.
I tried uninstalling the editor from the system, but still, it is not removed from the hub. I tried with a different version and met with the same problem.

Can you help me with this issue?

hi the downlaod of unity finished but it says “installing progress 0 of 2 copleted” and it stucked here

There can be a couple of things you might wanna check:

  1. Your Internet. Sometimes, the downloading of the Unity Editor can take a long time. If your network is having low bandwidth, then Unity Hub might have a problem with installing the Editor.

  2. See if your machine is meeting the requirements for downloading whatever version of Unity Editor you are trying to download.

  3. If there is another copy of Unity Editor on your machine already, then Unity Hub won’t download it again. Check if you have deleted every single piece of Unity Editor before you install the same version again.

If this doesn’t work then just reply and tell me.

Hi, I’ve had unity editer on my laptop before and it downloaded perfectly fine. Downloading this time however and it has failed continuously after my laptop had to be rebooted and everything wiped. Now it’s not downloading at all I’m really confused

How I fixed this is by tracking the download location which for me was as usual on “temp” and deleting all the files in that folder and reinstalling the editor

Steps:

  1. Press Windows Key + R
  2. Type %temp%
  3. Select all and delete

These are temporary files and even if deleted doesn’t really effect the system as much.

i found out how to solve it turns out all you need to do is restart your computer