Cannot start built in monodevelop

When I try to edit a C# file in Unity (version 3.5.3f3) on Mac OSX MonoDevelop shows up in the dock for a few seconds and then disappears.

Console shows the following:

01/07/2012 23:00:25.315 [0x0-0x4c04c].com.ximian.monodevelop: ln: /Applications/Unity/MonoDevelop.app/Contents/MacOS/../Frameworks/Mono.framework/Versions/Current/2.6: Permission denied
01/07/2012 23:00:25.316 [0x0-0x4c04c].com.ximian.monodevelop: Rewriting config files...
01/07/2012 23:00:25.364 [0x0-0x4c04c].com.ximian.monodevelop: cp: machine.config: Permission denied
01/07/2012 23:00:25.366 [0x0-0x4c04c].com.ximian.monodevelop: sed: machine.config: Permission denied
01/07/2012 23:00:25.377 [0x0-0x4c04c].com.ximian.monodevelop: cp: web.config: Permission denied
... (many many more following the same pattern but with different files having permission denied)
01/07/2012 23:00:30.103 [0x0-0x4c04c].com.ximian.monodevelop: Launching ...
01/07/2012 23:00:40.262 com.apple.launchd.peruser.501: ([0x0-0x4c04c].com.ximian.monodevelop[706]) Exited with code: 255

This was a typical install (no location change).
If i look for the path first mentioned “/Applications/Unity/MonoDevelop.app/Contents/MacOS/…/Frameworks/Mono.framework/Versions/Current/2.6” it doesn’t exist, in the Versions folder is a Current alias for a folder called 2.10.2 in the same Versions folder. Which I assume is the folder it should be trying to access?

Does anyone have any idea how I can fix this. I have tried deleting the app and reinstalling but that doesn’t resolve the issue.

Google or searching here hasn’t helped, but I did find MonoDevelop in Console - Pastebin.com which looks like someone has had a similar problem in the past but I can’t find any link to this to work out if the person resolved it.

Any help would be greatly appreciated as I’m very looking forward to getting started with Unity development.

Thanks in advance.

Also being frustrated by this, but not wanting to make my user an “admin user”, I did the following:

  1. Go to System Preferences->Users & Groups
  2. Click lock and log in as an admin
  3. Click the “+” to add
  4. Change the drop down to “Group” (from “Standard User”)
  5. Name the group. (I used “Unity Programmers”)
  6. Select the users you want in the group. (If this doesn’t come up, select the group by opening the “Group” item on the tree on the left and then clicking on your newly created group)

Now, you have a group of people that are called “Unity Programmers”. Now we need to tell Unity to let these people write to the unity application directory.

I had to do this under an actual admin account. So, I quick changed to my admin user and did the rest of these instructions under that account.

  1. In the finder, go to the folder where the unity folder is. (Applicatoins)
  2. Right click and select “Get Info”
  3. Open “Sharing & Permissions”
  4. You may have to click the lock to enable changes
  5. Click the “+” to add a permission
  6. Select the group you created above and click “Select”
  7. Click the privledge next to the group name and change it to be “Read & Write”
  8. Click the gear below the permissions
  9. Click “Apply to enclosed items”
  10. Click “Ok”

Now mono develop will open properly inside unity for any person that is a “Unity Programmer”!

Enjoy!

This happened to me, and a workaround was to give myself administrator privileges in the System Preferences (Users & Groups, “Allow user to administer this computer”). For security reasons I prefer to have a separate admin user rather than to run as an administrator, and it would be nice if you did not have to do this, but it works. It might only be necessary upon first launch of MonoDevelop (so it can run some initial installation setup steps) but I have not tried going back to standard user yet to test this (requires reboot).

Thank you for the answer!

I just tried this and making my user an Admin does indeed mean MonoDevelop runs as expected. Unfortunately it seems it doesn’t just need to run like this once, as if I switch back the user to be a non-admin and reboot I am back to square one with identical messages logged to the console.

Maybe Unity paired with MonoDevelop needs to be run by an Admin user? Does anyone here run the pair as non-admins on OSX without issue?

This should get me by in the short term though. Thanks again!