Facebook SDK - Login Issue on iOS: No Prompt/Login Dialog

I’m using Facebook SDK 7.16.0 and the target iOS version is 13.0. I’ve created a fb app which is still in development mode, used the fb app id and client token and followed all the steps from the fb guide to set up the login. I tested it in the editor, used the access token and it’s working.

Now, when I wanted to test it on the iPad, I created a build. Unfortunately SDK 7.20.0 wasn’t working as it had a bug. So, I downgraded to 7.16. No bugs.
When I hit the login button, it threw the following error.

-canOpenURL: failed for URL: “fbauth2:/” - error: “The operation
couldn’t be completed. (OSStatus error

So, I installed the Facebook App and tried again. The login doesn’t bring up the app or safari to login via facebook and instead in the result IsCancelled is true. Why? What am I missing?

FB.LogInWithReadPermissions(new List<string>() { "public_profile", "email", "user_friends" },
    delegate(ILoginResult result)
        if (result == null)
            Debug.Log("result empty.");

        if (!string.IsNullOrEmpty(result.Error))
            Debug.Log("error -" + result.Error);
        else if (result.Cancelled)
        else if (!string.IsNullOrEmpty(result.RawResult))
            Debug.Log("success - check result");

I’m running into this same issue with Unity 2019.1.4f1 and Facebook SDK version 7.16.1 which works on Android, but I get the same behavior you’re experiencing in iOS.
I’ve seen others with the issue here FB SDK 7.15.1 ILoginResult always return cancelled=true in iOS · Issue #385 · facebook/facebook-sdk-for-unity · GitHub

Their solution was to upgrade to FB SDK 7.18

I’ve tried 7.18.0 and 7.18.1 and run into this issue with both: 7.18.0 - iOS - module 'FBSDKCoreKit' not found when using Unity Cloud Build · Issue #350 · facebook/facebook-sdk-for-unity · GitHub

Switching to the latest available right now is 7.21.2 I didn’t realize that I had to open the “xcworkspace” project file vs the “xcodeproj” file I was typically using. I had a new error about something being defined more than once, this was due to my imports of multiple FB SDKs within Unity, doing so left some orphaned files, so after manually removing the SDK in Unity and re-importing the FB SDK package, opening the xcworkspace and building, it worked for me.

This combination is working with Android equally well. I’d like to use a more modern version of Unity, but I had some issues with the latest and some Android builds I was performing.