Fallback handler could not load library /Editor/Data/MonoBleedingEdge/lib/libvoxel DllNotFoundException: voxel assembly:<unknown assembly> type:<unknown type> member:(null)

I use Unity Editor to directly start my Dedicated Server, the approximate command is

./Unity -batchmode -nographics -buildTarget Linux64 -standaloneBuildSubtarget Server -executeMethod xxx

But this error was found during the startup process, the voxel file should be /Client/Assets It is stored under /Plugins, but why does it load under /Editor/Data/MonoBleedingEdge/lib.

The method I have tried

  1. I have also tried to put the corresponding so file under this path, but this problem still occurs.
  2. Also tried export LD_LIBRARY_PATH to modify the environment variable
  3. Try to change the name to libvoxel.so
  4. Try to modify the permissions.

I tried all the above methods and it didn’t work
My Linux Unity Editor version is 2021.3.27

1 Like

Hey I’m having a similar issue with 2021.3.28f1 also it batch mode similar behavior but in Windows and using fmod.

Do you get also an error regarding like the one below at any point on your logs?

Refreshing native plugins compatible for Editor in 6.64 ms, found 14 plugins.
Starting: C:\Program Files\Unity\Hub\Editor\2021.3.28f1\Editor\Data\bee_backend.exe --profile="Library/Bee/backend_profiler0.traceevents" --stdin-canary --dagfile="Library/Bee/1900b0aE.dag" --continue-on-failure ScriptAssemblies
ExitCode: 4 Duration: 2s499ms
Require frontend run. Library/Bee/1900b0aE.dag couldn't be loaded

I wonder if it’s related