Game Objects Not Appearing

I have just started using Unity and have found when I create a game object (i.e., a cube) it appears in the heirarchy, and appears to be able to be modified using the toolbar, but the game object never actually becomes visible (i.e. you can find the object in the scene but nothing actually appears or is visible in scene or game mode). If I however load an already existing scene I can see and modify these game objects no problems, I just can't create any new game objects.

I have taken a screenshot to illustrate the problem

Are there any settings which may be preventing me from seeing game objects? I have tried switching between RGB, Alpha etc and Scene and Game views as well as uninstalled and reinstalled Unity.

While you have the object selected in the hierarchy screen go with your mouse to the scene screen. Now click F and your camera should automatically relocate to find the object. If you still can't see anything increase the size until you do. It's for instance possible that you are right now so zoomed out that everything seems invisible. Hope this helps :)

Just discovered the cause was the 'default' layer was not showing. Thanks for the help guys!

OMG!!! It really worked :smiley: I got the same issue…The problem was shader, the default shader that unity provide for our game objects…Just change the shader from standard shader to legacy shader…then all of those game objects that were invisible will be visible :smiley: Hope this helps ya too :smiley: