MonoDevelop 4.0.1 code completion doesn't work

As the title says, the code complete feature doesn’t work in my MonoDevelop. It was working for Javascript for the last month, then I switched over to C# and noticed it wasn’t working, so I tested it again on Javascript and noticed that just stopped working as well. It looks like it gets the basic data types and keywords, but nothing Unity specific, like the ‘void’ keyword will be found, but beginning to type OnTriggerEnter doesn’t predict any results to help with the coding.

I know this question has been beaten dry all over the place because it seems this has been an issue with many and I’ve tried the following during searching for answers:

-Re-installing Unity/MonoDevelop several times

-Deleting all root files except the Temp, LIbrary, ProjectSettings, Assets folder (however problem this seems to be across all projects)

-Re-installing after the deletion of said files

-Sync’d MonoDevelop from Unity Editor

-Changed External Script Editor to point to MonoDevelop App instead of the default MonoDevelop App (built in)

-Deleted preference files from the Library folder relevant to Unity (plist, etc)

-Even tried moving the MonoDevelop app on a different level of the file structure but this seemed unnecessary due to it already being on the same level at the Unity app.

Basically… If you can google if, I’ve probably done it several times and did the steps above several times each in different orders, and I’m ripping my hair out doing so as my time would be better spent working on projects and not on this hinderance.

If anyone can help and offer a solution, I would greatly appreciate it.

I found a solution that worked for me. Apparently there is a problem if you are used network shares for storing files.

As per Don’t access Unity projects via network shares,
if you are seeing the “UriFormatException: Absolute URI is too short” error show up (especially when you Assets->Sync MonoDevelop Project) this is quite possibly your issue.

The Windows fix (before they fix the broken MonoDevelop code) is to map the network drive to a letter, and access the project under that drive. I’m not sure what the corresponding Mac fix would be.

This sounds really stupid, but I had declared a const before the class declation, after the imports, and the const was underlined in red in monodevelop. By moving the const to inside the class, autocomplete started working again. Hope this helps.