New package versions are shown as downloaded but I have never downloaded them.

Since Unity 2020.1.15f1, the Package Manager shows me new versions of packages, but I cannot download them because it appears to me as already downloaded.
But I have not downloaded these new versions and the file is still displayed on my hard drive with the old date and content.
This is also the case in Unity 2020.1.16f1.

Here is a screenshot of the Package Manager, the file on the hard drive in Explorer and the opened file in an editor with the version number in the JSON part.

This only affects the packages from the Asset Store, not those from Unity. I can still download new versions of packages from Unity.

3 Likes

Same problem, version 2020.1.16f1

Same problem here, Unity v2020.1.16 and v2019.4.16

1 Like

Hello everybody, sorry to see you are having this problem. I've been told that this is not necessarily a bug, as the publisher of the asset package could have bumped the version without uploading an updated package asset file.

In any case, to be sure what's the case for every one of you in this thread we need as much information as possible, which package asset you are having the issue, its version, which Unity version you are using. It's probably easier if you submit a bug as in that process all the information needed is collected.

1 Like

I’ve noticed problems with these 3 assets:

  • Odin - Inspector and Serializer (PM reported I already have version 3.0.2 though I never updated it. When tried to import it I got version 3.0.1 again. After few attempts I had to download and manually import this plugin)
  • Lean Pool (PR reports I have v1.3.1. When trying to import nothing changes in the project)
  • Modern Procedural UI Kit (MP reports I have v0.96.0 and doesn’t allow update, though I have v0.95)

Unity 2020.1.16 currently. Though I notices same problems from v2020.1.14 I think

1 Like

It definitely also affects packages whose content has been changed and not only “bumped” if I check the changelogs.

I also sorted the packages according to update date and I could no longer download an update for all the packages above the “ANIMALS FULL PACK” package.
I couldn’t update a single package since Unity 3D version 2020.1.16f1

1 Like

Same here… last date I was able to download an update was November 12, 2020. I’m running 2020.1.16f1, but also occured in about last 2 versions.
Here is a list of about half the updates it says I have the latest version but I did not download:

Also, maybe not hard evidence, but I imported Peek v1.3.2 that PM claims I have updated, when I check the version in Peek it only reports version 1.2.0. So how to now get the latest update to import? Do I delete the download from asset store directory then download fresh again?

ok, yes, I deleted asset from hard drive then PM let me download the fresh version and import is now up to date.

Can confirm this is also happening to me on Unity 2020.1.16f1, and is extremely annoying.

Hello everybody,

Thanks a lot for all the information provided. This is definitely a bug, can you please submit one and post here the case number? The page detailing the bug reporting process can be found here: Unity QA: Building quality with passion

Cheers,

Supi

1 Like

I submitted a bug report.
The case number is 1298335

3 Likes

Any news about this? I can’t update any asset from the Package Manager as it still reports that I have newest versions of everything though there are now at least 5 of them I didn’t update

Also experiencing this. Can’t update any Opsive packages.

Can we please get better regression testing for the package manager? This is a big one and shouldn’t have gotten through.

1 Like

Hey there,

I can see that the bug report is there and assigned to the team so they’ll respond within the report once they have an update.

I'm also having the same problem and I've just tried with the new tech release...
Unity 2020.2.1f1 + HDRP 10.2.2
e.g. Asset 'R.A.M.2019 - River Auto Material' - states the latest download is v1.4.4
- but when I check the available files for import, compared to those listed in the package on the asset store, there are not HD10.2 files - i.e. this is NOT the v1.4.4. latest version...
I updated to the latest tech release as that's meant to fix asset store problems, but it doesn't help.

i.e. The asset version listed in package manager, is NOT the same as the one that gets imported.
I'm unable to import the latest asset versions :/

Bug present in 2020.1.17f1 too. I just saw it when I didn’t get the new files changed today by the author of the asset, “Meadow Environment - Dynamic Nature”. Asset version in Asset store: 2.3.4, Package Manager report 2.3.4, but file has not been changed since May and some update files that I need to update shaders for URP are still only for 7.2, even though the author have added for 10.2 today.

Same as previous writer, unable to import the latest version. :confused:

1 Like

@andersma @Waterlane As a workaround, you can manually delete the asset in the assets folder of your file system and download it again through Asset Manager to get the latest versions of the assets.
The location of the asset folder in Windows is "C:\Users*username*\AppData\Roaming\Unity\Asset Store-5.x*plugin_developer**plugin_name*.unitypackage".
I do not know whether the folder Asset Store 5.x is called the same with you, or whether it only comes from the updates since Unity 5.

[EDIT] I found the latest locations in the Unity3D Documentation: https://docs.unity3d.com/2020.2/Documentation/Manual/AssetPackages.html

macOS: ~/Library/Unity/Asset Store
Windows: C:\Users\accountName\AppData\Roaming\Unity\Asset Store

2 Likes

@supita_unity - I just uploaded a package, and definitely updated the version number. The new version shows on the asset store. The Package Manager thinks it's already downloaded - but it's not. Hitting the import button imports the old version that is downloaded.

2 Likes

With the release of Unity 2020.2 breaking some of our stuff we pushed a massive update before christmas.

Now we are getting people having a go at us for not insta supporting it, despite the fact that we have, and I know other publishers are all having the same problem.

This issue has resulted in a whole lot of unnecessary support requests for publishers, and a whole lot of angst for our customers.

Let’s hope it is resolved quickly.

6 Likes