new uGUI mask doesn't work for some android devices.

I have many devices, and on one of them, the mask does not work correctly.
Does someone have the same issue ?

This is on a Wiko Clink Slim (Android 4.1.1)
The English button does not use a mask, the rest does.
If you look closely you can see that rounded borders have the color of the Image behind.

This is on an Oppo Find5 (with android 4.4) and it work as expected


1 Like

Yes some android devices although they support the stencil API arnt behaving correctly (i know the original kindle fire is one). The android team is looking into this.

1 Like

Filing this one under The Joy of Developing for Android

2 Likes

Is there any Issue report ? So I can follow it :wink:

@eXiin
Hey, Did you know that your Chinese language option doesn’t actually read ‘Chinese’? [中文]
It reads ‘Pinyin’… Which is the phonetic system for transcribing Mandarin…

Maybe you already knew that… :wink:

I’m not 100% sure where the bug is atm, all i know is someone on the android team is looking into it.

@FuguFirecracker , Well I’m currently using placeholder as the game is not finished yet,afterwards I’ll ask someone to translate it :slight_smile:
but thanks it’s very kind of you to notify it to me!

in beta 30 still the same problem, and it’s very important to me to have a mask to scroll a text in a scrollrect…

Is there any known workaroud?

nope no known work around that i’ve seen. when we fix it i’ll be sure to mention it in the release notes.

I’ve also seen some weird masking bugs on Android. On my Sony Xperia, elements inside a scrollRect and mask turn into hundreds of tiny pixels which vaguely make out the images they’re supposed to be.

Any news on this? 4.6b21 and scroll rects with masking break with OnePlus One.

I tried an older b19 development build and it worked fine. Non-development b21 doesn’t.

Exactly this happens on OnePlus One as well (at least) in b21 release builds. Development build is somehow unaffected.

Are there any bug numbers?

Here’s mine:
http://fogbugz.unity3d.com/default.asp?641794_v56h034n5j19qhs1

Masks don’t seem to work correctly on the Galaxy Nexus running Android 4.2.2. This is for Unity 4.6 RC1

Hello.
Bug looks like mask’s image is drawn like usual image - and we see only white image instead of items under mask.

I have reproduced this bug with 4.6b20 on two devices:
Highscreen Alpha GTR
LG Optimus L4
both uses video-chip PowerVR SGX531

Hope, it can help you to fix it.

Hello guys,

are there any news ? Because i have the same Problem…

-Keyjin

push…

Reported on B17, still available on RC3. Filed bug as well…

1 Like