Unity 2018.3.8f1 HDRP : Area Light Shadows feature not showing for Area and Tube Lights

Hi All,
I am using Unity 2018.3.8f1 along with the HDRP pipeline. The issue is when I create an area light or a tube light the “shadow” feature does not show up in the light component. So the area/tube light is not casting shadows. The area light is real time.

The "spot,directional,and point lights all have the enable shadow setting for each of those light component types but for some odd reason the area and tube light do not. I am not sure if this is a bug or if I am missing a step.

I know this is an old post but area lights are only baked. there are no real time shadows for area lights. you have to bake these lights. also make sure to bake as baked indirect.