Unity 5.5.0f3 freezes at splash screen

Hello, first time poster here so I dont know if I’m posting this in the right department.

About two weeks ago I updated to the newest version avalible for unity (5.5.0f3) since I needed the colaborator tool for a school project. After updating it worked great, managed to work on the project no problem. However, about a week ago my unity refused to go past the blue splash screen you get when booting up unity(the unity editor is what I refer to whenever I talk about unity/this splash screen). Ive tried to let it run for a few hours incase there was just a small kink it needed to overcome, ive tried reinstalling, ive tried deleting/regediting away every trace of unity and visual studio I can find on my computer, then reinstalling, I’ve even tried the former then installing a fresh 5.4.3f1 version of unity but still stuck with the same problem.

(Blurred out the rest of the desktop for my own paranoid internet reasons)

Aswell as just not doing anything as seen in the task manager the unity editor simply starts an empty task and just stays in the background not doing anything.

And if it is of any use some specs of the machine that gives me my troubles:
OS: Windows 10 (Version 1607)
CPU: Intel Core 17 4930k
GPU: Zotac GTX 1070 Founders edition
OS disc: Samsung EVO 850 250GB SSD
RAM; 24GB HyperX Beast from Kingston

UPDATE: I have now also tried to once again remove all local files I could find and install the new version of Unity (5.6.0b3) and I’m still stuck with the same problem so there seems to be some external piece hindering my unity from launching and not necessarily a problem with unity itself. I’ll leave this thread open in the hopes that some resolve can be found, but if you arrive here through some internet search the only solution currently found is to reinstall windows/backup to a previouse image if you have that.

Has anyone out there in the far and wide-spread community ever encountered anything simmilar to this or have any wise words of wisdom in my times of need?

Thanks for your time :slight_smile:

This is a bit a shot in the dark but you could try to delete or rename (for backup reasons) the following directories:

  • %HOMEDRIVE%%HOMEPATH%\AppData\Local\Unity
  • %HOMEDRIVE%%HOMEPATH%\AppData\LocalLow\Unity
  • %HOMEDRIVE%%HOMEPATH%\AppData\Roaming\Unity

That last one stores your licence information in a file called Unity_v5.x.ulf, backup that one if you are using anything but the free licence.

The files in these directories don’t get removed when uninstalling and are shared between unity versions. They hold configuration information like the layout of your Unity window, settings from “Edit > Preferences” etc.

Found out what was causing the error. It turned out to be AVG Antivirus that was screwing with unity. Removed it and its now working fine.

I wanted to post this as its own comment to hopefully make it more visible for those who just stroll by and dont want to read all the jibber jabber in the original post :slight_smile: