unity and autocomplete visual studio code

Hi

I want to start with Unity but my autocomplete dont work. I think the problem is that I have 2 visual studio codes on my computer. In external script editor I only see visual studio code and not the version. Do someone now how I can fix it?

8767705--1189207--upload_2023-1-30_16-14-15.png

8767705--1189219--upload_2023-1-30_16-25-37.png

did you install the C# extension and NDK? also, in the external script editor, you can chose the browse version to select whichever VS code version you wanna use.


refer to this tutorial for setting up intellisense

2 Likes

I followed the video and fix the problem, I didn't know about the output in VS.
The error was something else.
Thanks.

The issue was this:
Could not locate MSBuild instance to register with OmniSharp

And this was the fix :)
8768065--1189315--upload_2023-1-30_19-33-24.png

8768065--1189303--upload_2023-1-30_19-8-59.png

1 Like

I found another setting that will cause autocomplete to fail. This typically happens when starting a new Unity project.

In VS Code go to File -> Preferences -> Settings. There search for preferCSharpExtension. Make sure this is unchecked. If it's checked your C# Dev Kit will be disabled and auto complete will not work.

It should look like this:
9578023--1355887--upload_2024-1-12_12-57-27.png

1 Like