Unity Hub not installing Android SDK correctly?

I just did a clean install of 2019.2.2f1 via Unity Hub, including the Android Build Support module (SDK + NDK and OpenJDK).

When I open my project and try to build for Android, I get an 'Unable to locate Android SDK.' error. Looking in the logs, it seems like it has no problem finding the JDK, however.

I tried uninstalling and re-installing the editor alone, then adding the Android modules separately, but I received the same error when I try to build.

If I look in Preferences -> External Tools 'Android SDK Tools Installed with Unity' is checked and it does seem to recognize the SDK. If I uncheck this and try to manually point it to %PROGRAMFILES%\Unity\Hub\Editor\2019.2.2f1\Editor\Data\PlaybackEngines\AndroidPlayer\SDK, I get 'Unable to detect SDK in the selected directory.'

Am I missing something? Are there additional steps needed to install the Android SDK via Unity Hub?

2 Likes

Hello @cdauphinee , if you are on Linux, it's a known issue that will be fixed soon, in the meanwhile try installing the SDK tools manually for your editor. If not, it seems like a bug, please report it with the hub bug reporter. Thank you for your feedback.

@safaGH I'm on 2019.2.4f1 (Windows) and the issue is still available

@safaGH I'm on 2019.3.0f3 (Linux) and the issue is still available

1 Like

2019.3.0f6, Windows, issue still occurring.

2019.3.0f6, same problem

I got it to work. However it was a bit of a hassle so I recorded a video.

https://www.youtube.com/watch?v=yT8QUlRS2d8

3 Likes

2019.3.0f6, same problem

[quote]
I got it to work. However it was a bit of a hassle so I recorded a video.

[/quote]
True, the hub was installing SDK and NDK android build support modules in the wrong destination. With the new version of the hub, this should be fixed. On which OS are you @salvadoragati ?

1 Like

same problem 2019.3.0 and 2019.3.1f1. Using latest Unity Hub. Installed fresh 2019.3.1 hoping to get the files from there for 2019.3.0. Im on win10
@safaGH For these events, it'd be helpful you publish the relevant recommended versions to use so we can download/install them ourselves, otherwise it's quite a guess work
I have tried setting path for JDK with packages jdk 1.8.0_172,_181,_192,_241 and all give red warning not installed with unity and use the hub or provide custom location :(

I was having trouble figuring out how to load the SDKs from the Hub as Unity said I should. Then I realized that in the Add Modules section, next to Android Build Support it wasn't good enough to just check that box. You have to actually expand that section with the little arrow and then manually also check the two boxes to install the Android tools!
Once I did that, I was able to build with no problem.

Maybe this is obvious to everybody else, but it escaped me for a while and was frustrating.

5607523--580321--Unity-Android-SDK.gif

15 Likes

For the lost soul looking high and low for how to do this on Windows (I know, not this thread, but I searched everywhere and found this thread and nowhere found answers) https://forum.unity.com/threads/setting-up-android-jdk-and-ndk-for-unity-2018-4-18f1-lts.838015/#post-5549776

1 Like

Hi guys, the same issue persists with me on MAC. The problem is I am almost completely new to Unity and this is such a huge head-ache. I tried installing them seperately and through the HUB. :( I am really frustrated as this has been impending progress for 3 days now.
It seems to be able to locate JDK but can't find NDK and SDK and I can't open them manually through External Tools as it says INVALID ANDROID DIRECTORY - unable to find ndk in directory. Same goes for SDK. Please advice!

1 Like

Still occuring on Hub 2.3.0 and Unity2019.3.4f1
I found this installment(include SDK+NDK and OpenJDK) will be OK when I installing Unity
BUT after that, I still can not build Android in Build Settings dialog, it show a download button, after downloading UnitySetup-Android-Support-for-Editor-2019.3.4f1.exe this file, but this installment will remove and delete all files in Unity\2019.3.4f1\Editor\Data\PlaybackEngines\AndroidPlayer folder and install itself files, so I think this is a mistake loop forerver, you install sdk but no support for editor, you install support for editor but no sdk

1 Like

God bless you man!!


You made my day!! thank you!

I am encountering the same problem and I am using: Unity Hub 2.3.0 and Unity 2019.2.13f1

1 Like

I have unity hub version 2.3.1 and it's still showing corrupt download files. Also I tried downloading unity without hub but SDK and ndk gets missing. Even after adding them in the unity folder, it is not working. Any help

@codemonkk

I am also facing same issue from last three days. tried many things to get rid of this.
But still no luck.

Can anybody from Unity Team look into this issue.

Steps to reproduce issue:-
1)Working on window 8.1.
2)Installed Unity Hub 2.3.1
3)Added module Android platform with android sdkn ndk checked , visual stdio
4)It is unable to find android sdk in unity preference(error message:you are not using recommanded version of android sdk)

First day back on unity in 8 years. I came to this problem.

Managed to figure it out and fixed it.

If anyone needs info on how let me know, as it was quite simple in the end.

1 Like