Does the "render outside safe area" player setting not affect simulations?

I have the mentioned player setting unchecked. Yet the objects seem to be rendered outside the safe area. I am using Unity 2019.3.2f

You need to uncheck the ‘Full Screen’ setting in the device simulator UI.

Note: if you don’t have installed iOS or Android platform build support you won’t be able to change this setting on the missing build target