Everytime I add Cinemachine Confiner to my 2D game my player falls through the floor?

,I followed this tutorial: Cinemachine for 2D: Tips and tricks | Unity Blog

I followed it exactly. After I put everything in the GameObject that makes the boundary suddenly my player falls through the floor. When I remove it everything works normal and how it should again. How do I fix this? I have no idea why it would affect my character when i didn’t add anything new to my players components.

Aside from this tutorial I’ve also tried just adding the Polygon Collider straight to the background and it does the same thing.

I’m new to Unity so I’m at a loss.

One reason behind the issue could be
You have collider on the player and also on the GameObject that you have used for confiner. Both are on the same layer i.e Default, due to which there is a collision between the two.

How I fixed the issue is I added a new Layer “Bounds” and applied it on the GameObject used for the confiner.
Go to Edit → Project Settings → Physics2D and unchecked Default checkboxes for the new bounds layer, because I don’t want physics to work between these two layers, my player is on the default layer.

Is your camera boundary collider set to ‘Is Trigger’?