Getting the Unity Editor to Work in Windows 7 64-Bit

Unfortunately, I've just done the install of the Unity Editor on Windows 7 64-bit and can't get it to open. I've tried running it "as an Administrator" and in multiple compatibility modes, including XP and Vista options. No dice! Any help is appreciated.

I get this error:

Problem signature:
  Problem Event Name:   APPCRASH
  Application Name: Unity.exe
  Application Version:  2.6.1.31223
  Application Timestamp:    4b13e3a0
  Fault Module Name:    KERNELBASE.dll
  Fault Module Version: 6.1.7600.16385
  Fault Module Timestamp:   4a5bdbdf
  Exception Code:   e06d7363
  Exception Offset: 0000b727
  OS Version:   6.1.7600.2.0.0.256.48
  Locale ID:    1033
  Additional Information 1: 236e
  Additional Information 2: 236e213616a19c43b9b4f484bab02c9e
  Additional Information 3: f0fb
  Additional Information 4: f0fb81261199e5edc1200c7838f5a558

Thanks for the tips, but none of these suggestions have helped yet. I've tried:

  • Disabling antivirus (Panda Cloud AV)
  • Multiple NVidia drivers
  • Installing in a new user profile
  • Making sure all Windows updates (optional as well) are installed, especially display drivers
  • I reinstalled IE8 through the Programs-Features>Add/Remove Windows Services, then reinstalled Unity. Rather than crashing, Unity seems to start, then silently refuse to boot. Period. No APPCRASH, but also no Editor! Jen Grier 15 hours ago [delete this comment]
  • As a temporary workaround, I've tried running Unity on Virtual PC and VirtualBox with Windows XP installs, but VPC doesn't have 3D acceleration support (blasted!). VirtualBox DOES get Unity to open, but the windows/panels appear in flashing colors. I can navigate around the Island demo project, but it's not a workable scenario.

If you have other suggestions, please post them! I've tried the first two given, but I haven't fixed this yet.

FINALLY figured out the solution: had to create a DEP exception for Unity. Runs without a hitch now!

I've been running Unity 2.6.x under Windows 7 64-bit for quite some time now with no problems.

My best guess would be that this is a problem specific to your particular setup. Sometimes bad or out-of-date drivers can cause these kinds of errors, or sometimes it's another program installed that conflicts with Unity (absurd as it sounds, I know).

The best advice I can give you is to update all your drivers (and make sure you aren't running any beta drivers). You could even try running Unity under a different account in Windows, and with no other programs running in the background.

You could also try checking Windows Update for any new compatibility fixes, as most of the time they are marked as optional and might not install automatically.

However, as said earlier Drivers are typically the reason programs do not run properly. You may even try using an earlier version of a Driver. Occasionally the most up to date Driver will break programs that ran well under a previous version. This has been the case for me a number of times with ATI's updates.

as developer its normally in your best interest to set DEP to what it should be outside a restricted environment anyway: set it to protect os services instead of having it running in paranoia mode.

This recommendation is one I give cause you will find out that there are applications that will malfunction and finding the issue then, get it into relation of DEP can be near impossible as you forgot about DEPs dark sides by then.

DEP Exception worked for me as well, Thanks. Windows 7 home premium 64bit, HP laptop

you can isolate the scene that has the problem, in my case, i have to do, and i found a Particule Animator in one of my objects, so I remove it and everything run fine.

Make backup of the problematic scene and delete one by one of objects that have particule animator.

after trying updating everything, and disabling the DEP for Unity, I finally found that the problem was in a script that had entered an infinite loop of creating objects that created more objects of the same type. I just had to move the unity projects folder from the documents so it would create a new project and then re-installed unity. I probably didn’t need to re-install unity to fix the problem though.

DEP doesn’t work for me, it says i can’t apply it to a 64bit program and Unity 5.4.2 is installed as 64bit.

If disabling firewall, making DEP exceptions, and running in Compatability Mode doesn’t work, it’s likely that it’s because you don’t have KB3063858 or KB4457144 installed. The minimum is KB2533623, but it cant be downloaded since Jan. 14 this year. The 2 listed here are successors to it, KB4457144 being the latest one, but if it cant be installed, KB3063858 is sufficient as well.