Highlight displayed on the transparent part of an object when using Lit shader

I have a weird issue when using Lit shader. I can see a semi-transparent highlight on the transparent area of my object. I believe it maybe related to normal map.

This issue doesn’t appear when using Unlit shader. However, I can still see the highlight if I change my shader to Unlit only, without disconnecting the disabled Smoothness, Normal and Metallic properties.

I don’t see this issue in the Unity Editor, but I see it on visionOS simulator.

Unity 2022.3.12f1
PolySpatial 0.6.2

We currently use the presence of these properties to indicate whether to generate a Lit or Unlit shader, so basically you’re ending up with a Lit shader despite the Material property being set to Unlit. I’ll make a note to fix that.

This seems to be inherent to the visionOS material. In Unity, materials have a “Preserve Specular Highlights” option that, when disabled, ensures that specular highlights aren’t opaque on transparent objects. There’s no equivalent on the visionOS material that we map to, but I did find that setting the Smoothness to 0 and Metallic to 1 removed the highlight.

Thanks for your information.