How should I start 3D Platform Tutorial in Unity3?

I've downloaded the 3D Platform tutorial (Lerpz) but I'm stuck on basically the first step:

"Move Lerpz onto the raised platform with the Jump Pad (the niche with the yel- low chevrons), near the Jail. (See the screenshot on the next page.)"

The problem is, I don't have the raised platform showing in the scene view: screenshot

I'm using Unity 3.3.0f4 and the first thing that it does when I open the project is to upgrade the project, going through most or all of the assets. That appears to complete correctly. Win7-64 if that makes a difference.

Does this project work with Unity 3.3.0f4? If so, what do I need to do?



Well never mind, I guess. It seems to have fixed itself, so I went back and tried to recreate the steps to fix it. Here's what I did:

  1. Started Unity first, and then opened the project from inside Unity by browsing to the project folder.
  2. Unity upgrades the project and opens it.
  3. Click spaceship in the hierarchy, and type F to focus and center.

The problem is that I tried doing that the first couple of times, and typing F did nothing. Then suddenly it started working. Now I can't seem to revert all the way back to the original starting place - Unity opens the project with the camera in the same position as wherever I left it, even though I've deleted the project folder and extracted it to a different location.

I'm happy it's working, but I wish I knew why.

It may be due to some layers settings (top right)..