How do I turn off Collaborate AFTER PlasticSCM Migration? The Auto-Migrate of Local Workspace is not working as expected.

Hello all.

I have a pretty urgent and very aggravating problem that popped up earlier this week. I am working as quickly as I can on a fast turn-around client project, but despite all the newsletters and announcements, I somehow missed the fact that Unity Collab was being sunset in favor of Plastic SCM. I learned this the hard way when my editor locked up the other night and I was unable to kill the process in task manager or by killing the task tree.

I restarted my computer to terminate unity and then started it back up. Since I did this the first time, I have been getting the following Errors spamming my Console roughly every 1 second:

As you can see in this screenshot, Collaborate is set to “ON”. I am a manager of the organization account on the Unity Dashboard, and for the record, I am using Unity version: “Unity 2019.4.36f1” which should be compatible with PlasticSCM for Unity as described in the blog post here

I’ve read on other Forum and Answers posts regarding disabling Collaborate that there is normally a toggle switch on the Collaborate page that is reached by clicking on “Collaborate” in the services list shown. However this toggle switch does not exist when I click “Collaborate” in the first Image. Instead I simply see “Collaborate”, “Create Together Seamlessly” and a Box about “Join the Collaborate Beta”. The toggle switch in the top right is missing, and I am occasionally seeing the following a “You do not have permissions for this action” error at the top of the 'Services" window. This is weird to me as I am logged into the editor with the same Unity Account that is a manager for the organization through which the project is hosted on the Unity Dashboard.

What is suggested by all of the blog posts and resources that I have read regarding the previous update to PlasticSCM was that all projects using collaborate that are using an acceptable editor version (which I believe mine should be as it is “2019.4.32f1 or later”) should have PlasticSCM for Unity autodetect the fact that the local project is using collab and start migration to a PlasticSCM workspace (including the project that I am posting about, which has–and has previously had–collaborate enabled, and had a version on collab as an unarchived project). The autodetect shown in the blog post’s videos is not happening and I do not have a PlasticSCM icon near the Cloud and “Account” buttons in editor. This lead me to believe that I didn’t have the package installed, however, my Package Manager shows “Version Control” version 1.14.18 in my list of packages “In Project”.

This lead me to believe that Collab being enabled is blocking PlasticSCM for Unity from doing it’s job. I am trying to turn off collaborate and switch over to PlasticSCM, but the automatic local workspace remapping is not working. I did get a confirmation email that the collaborate project was in fact migrated to PlasticSCM on the cloud, but again, I can’t seem to get PlasticSCM for Unity to work in editor and–more importantly–I can’t seem to turn off collaborate.

I even tried going into the ProjectSettings file and even ensureing that all “cloudServicesEnabled:” are set to 0 and that “cloudEnabled: 0”.

How can I turn off collaborate entirely and stop this horrid stream of HARD collab errors?
Bonus points if someone knows how to get PlasticSCM working.

I’m really at a loss and at my wits end here. Any help is greatly appreciated.

Hi, I had the same problem.

It didn’t migrate automatically.
I don’t remember the exact step as it was few months ago, but I remember it was a bit hard to do.
I will try to give some advise what I remember…

  1. Switch off collaborate.
    First of All I think you need to turn off Collaborate completely → switch it to OFF.
    The new Plastic SCM version control will work completely outside of the collaborate setting.
    Make your Project local only without any source control - just for now to make sure you get rid of collaborate.
  2. Plastic SCM is another Software outside of Unity that you need to install and make the account. Then you need to setup your repositories and workspaces there. Its also not that easy at first and it took me time to figure it out as collaborate was more automatic. It took me some time to find the way to sync between laptop and desktop. I mean its pretty easy but I never worked before with Version control software.
  3. In the package manager download Version control. That is the unity asset that will work together with Plastic SCM software. You have now Version control → Plastic SCM in project settings and also you have Window->Plastic SCM.

Hope this can guide you in the right direction.

So, a workaround for this:

In your ProjectSettings.asset file, set all flags under “cloudServicesEnabled:” to 0

like so:

  cloudServicesEnabled:
    Collab: 0
    UNet: 1

Delete the projectName, cloudProjectId, and organizationId fields (its a good idea to copy these to another file before deleting in case you need them later).

Set the cloudEnabled flag to 0.

Close any open Unity Editor instances and save this file.
When I followed these steps and relaunched the editor, it took a few minutes after the editor started up, but the editor eventually recognized that cloud services were off, and the PlasticSCM plugin in the version control package started working properly (a.k.a."Enabling the PlasticSCM icon in the top right of the editor, and allowing the PlasticSCM window to be opened from the “Windows” menu.)

From this point I connected to PlasticSCM and was able to reconnect to Unity Cloud Services.