Models get much darker when switching levels, but are fine when playing the scene normally?

Hello all!

I’ve been working on a personal project for the past couple of weeks, which so far has come along nicely except for this bug. I made some pretty big models in blender earlier today and decided to put them in a test scene to see if they worked well in proportion to all the other models. Fortunately, they turned out okay! So I started adding textures and materials to the models and set up a script to load the current level after the player is finished with the previous one. When I loaded everything up and got to the second level, everything was EXTREMELY darker than before. If I loaded up the scene and played it there, everything was fine, but if I loaded the first level and made my way to the ending and got to the second level that way, everything goes wrong. I also just switched my project over to Unity 5 by the way, never had a problem like this before.

Any suggestions?

This is because you’re continuously baking the lighting. Don’t worry, as this will be changed automatically once you build the final game.

To fix it in the Editor, go to Window → Lighting → Lightmap Tab → Disable Continuous Baking → Press Build to bake the lighting.

Note that if you add more lights or make some changes, you have to bake the lightmap again.

Yup, on 5.6.1f1

you will need to make the following change on each scene

Lighting → Scene (Tab) → Lightmapping Settings (Section) → uncheck “Auto Generate” then click on the “Generate Lighting” button.

seemed to do the trick for me.

I found that by disabling “Continuous Baking” in Lighting > Scene > Other Settings and bake manually everything is working fine.

I think this has changed, yet again, in 5.6.

For Unity 2017.2.0f3 Is Work for me

Tutorial on youtube : Fix Lighting Going Dark in the Unity Editor When Resetting a Scene - YouTube

As Wizbit said, in unity 5.6 you have to go to
at the very bottom it says auto generate.

  1. Uncheck auto generate
  2. Press the Generate Lighting button
  3. I am unsure but if you still have the error then repeat this setting on every scene

I think this has changed, yet again, in 5.6.

I think this has changed, yet again, in 5.6.

Building the final game does not seem to change this. Am I missing something? It’s the same problem, if I bake by hand things work correctly on the editor. But after building both the stand alone version and a WebGL version the problem is there! So frustrating.