Shadows appearing in editor view and not game view

Hi, I have a big problem that my game looks good in the editor view and has shadows but the game view has no shadows. This is really annoying and I need to fix this soon.

You likely need to turn up your shadow distance, under Edit>Project Settings>Quality.

its very simple… you placed the point light on the camera, that is why you cant see shadows, because the field of view of the camera cant access it. It is the same while recording a video with flash using your phone, you cant see any shadow, you see all things lighted, so to solve that, you can just move the light point slightly away from the camera, so that you can see your shadows!

Go to: edit>project settings>graphics>Shader Stripping>Lightmap modes> Change “Automatic” to “Manual” and set all options.
OBS: Make sure the scene name is the same as the folder containing the lightmaps.

My issue was that I had the object casting the shadow rendered by a different camera. Make sure everything (the light, the object casting shadow, and the object receiving shadow) are all all on the same camera layer. You can also duplicate the mesh of the object casting shadow, and make it a “shadow only” in the “Cast shadows” setting, and then only move that object over to the camera-rendering layer.

Making a top down game, i had set the cameras far clip plane to barely include everything. Increasing the far clip plane solved it.