The Panoramic skybox has a seam line

The Panoramic skybox has a seam line, unchecking the mipmaps option fixed the issue but instead, it made the texture appear with noise(The panoramic image is of high resolution, and compressing it in compression settings resulted in a noisy texture.). how to fix the seam line with the Mipmaps option enabled or the best compression for a higher resolution texture with the Mipmaps option disabled.

Without noise <-|-> With noise