Unity won't open project

Hey,

fast in short. I have 2017.1.1f1 personal version Unity. And what’s up with Unity it can’t open project? I’ve been working for like 8 hours and if I want to re-open to check something or etc. it won’t open. Does this happening only to me or I’m missing something?

One thing found helped me is go to Task Manager and End Process Tree on Unity, but I shouldn’t go there every time it does “this thing”.

Any help is appreciated.

@iKazanova -
Just experienced this issue and tried this solution on two different projects and it resolved both issues:

Under your project check the Temp folder for UnityLockFile. Delete it and try to open the project again. Click OK on the popup that you get on opening.

It looks like Temp should not exist if Unity was properly shut down so you may be able to remove the entire folder.

UPDATE:

Steps taken:

  • Prior to removing the lock file I had completely uninstalled (Uninstall, delete extra folders, purge registry) all versions of Unity. After reinstalling the issue still existed so I do NOT recommend doing this.
  • I tried deleting the lockfile on one project that was having issues and it resolved the issue. I tried deleting another lockfile and that project also opened. After the second project opened I tried the other projects and they all opened without having to deal with the lockfile. It may be the case that removing the correct lockfile will resolve the issue.

Other Options:

  • I have also seen a lot of posts that state opening from an open project resolves the issue. If you can find a project that opens, open it and then open the locked project.

  • If none of these options work then you can also send a report to Unity support. You have to include the affected project and it takes a while to send but may be worth it for a solution from Unity.

If you have any controllers plugged in try to disconnect them. Worked for me

I don’t normally have any knowledge to help people, but I just thought I’d add in that had similar issue as @eovento, I’ve been using unity with no problems at all for a year or so - last month I got SurfShark VPN and everything stayed as normal. This week however Unity just wouldn’t load, no crash report, just failed to get past the unity splash screen - did the usual of uninstalling Unity, upgrading to Unity 2020, still no luck - disabled my VPN and bingo, Unity works again.
Why the two don’t get along I don’t know, but thanks to @eovento for the info.

Having this issue after Unity crashed while importing an asset.

I can open other projects, but not this one.
Unity process disappears without any report right after clicking to open my project.
If I delete the temp folder or the UnityLockFile, Unity creates them, then crashes directly without any report.

Opening it after opening another project doesn’t change anything.

I have the same problem as Xialya do. Sended crash report.


UPDATE

git clean -fxd helped me (this command deletes all files that not present in git repo)


CAREFULL some editor settings can be lost


.gitignore

/[Ll]ibrary/
/
emp/
    /[Oo]bj/
    /[Bb]uild/
    /[Bb]uilds/
    /Assets/AssetStoreTools*
    # Visual Studio 2015 cache directory
    /.vs/
    # Jetbrains IDE cache directory
    /.idea/
    # Autogenerated VS/MD/Consulo solution and project files
    ExportedObj/
    .consulo/
    *.DS_Store
    *.csproj
    *.unityproj
    *.sln
    *.suo
    *.tmp
    *.user
    *.userprefs
    *.pidb
    *.booproj
    *.svd
    *.pdb
    # Unity3D generated meta files
    *.pidb.meta
    # Unity3D Generated File On Crash Reports
    sysinfo.txt
    # Builds
    *.apk
    *.unitypackage
    # Save data
    /Assets/Save/
    /Assets/Save.meta

I have a solution for this problem

  1. Go to your project Assets
  2. Select everything in there and copy it
  3. Make a new unity project and go to the Assets of that unity project
  4. delete everything in the Assets of your new project and paste your old Assets in there
  5. wait for unity to load if your new project was still open
  6. Now the only thing you need to do is change the project settings back to how the where
  7. It worked for me :smiley:

sorry for reviving a dead thingy here but
check that the hard drive/folder that you keep projects in is not read only

anyone read this post may solve this problem.I got the same issue when i upgrade my unity hub, just reinstall the Unity editor so you can fixed it. I noticed there is a little change with the version number,which the old one is 2019 4.37 but the new one is 4.38,and 4.37 was gone in editor list, i think that is the matter.When i reinstall the 2019v but the new one, all the issues were gone.(contain ‘can’t open the project file’)

I have been experiencing the exact same problem in the past few days, and I have to End Process the Unity.exe in the Task Manager every time! I thought it was because of my version: Unity 5.6.1f1
I’ll keep watching this thread for answers!

I have the same problem. I was able to ope projects by deleting all the folders and files except Assets and Project Settings. Unfortunately this method doesn’t work for me anymore. So I uninstalled Unity and then reinstalled it. It worked once and then failed again. Now I not only can’t Open Project, I can’t even create New Project. What is happening? Can anyone help, please?

Yep, here to add another case :

  1. Opening untiy
  2. create project
  3. then…nothing…

So what’s going on, please ? @ Unity support ?

I have same problem Help plss!,I have got same problem. help plssss!

I have been troubleshooting this extensively. Nothing seems to help. It really is intermittent so it appears that deleting folders and files works, but it doesn’t open the next time and there seems to be no way to get out of it once you try one time. I have to unplug my computer (somehow it interrupts even the shutdown process)

Having a similar problem, I tried opening my Unity 2018.2.5 project with this same version, didn’t work, and I then tried with 2018.2.7, didn’t work neither, and deleting the UnityLockfile doesn’t change anything :confused:

I got this problem after Unity crashed for unknown reasons, and I always have to end the process in the task manager :confused:

Same problem here.
Im new in unity so spend last 8 hrs with learning.
Day after I try to open a existing project to continue the same issue.Unity is already in list. You cannot locate the same version.(must click a 20x times to read that flash message appear under HUB)
Im using a Unity personal version 2019.3.0f1, so every time I start the Unity HUb warning that I dont have a active licence.
Try every time with manual activation. But problem not solved. Unity is already in list…
So I found the solution. Its work for me maybe it will be helpful for some of you.

  1. Delete the /ProgramData/Unity
  2. Turn off windows Firewall
  3. Turn off the internet connection
  4. Launch the Unity HUB
  5. Manual put the licence until write that cant connect to server
  6. Turn on the internet connection
  7. Dismiss the all warning and under HUB until my licence was accepted and activated
  8. Open through HUB the last project and it normally start
    The reinstalling Unity or HUB and etc didnt work for me problem was again and again and reinstalling the Windows was insane if that bug is there so can happen any time.
    Maybe it help for some of you. Cheers

It would normally sound strange, but nothing sounds strange in this thread anymore: are you guys using VPN?
To me it started exactly at the same day I started using VPN. At first, logic was not allowing me to correlate events, but after reading here about rebooting, turning connecting down, running Unity and then restoring connection I started to connect the dots.
Changing the server have an influence on the matter for me.

About the case, I just had this for the first time after working on a project for 8 months now.
Unity would always recreate Temp folder and UnityLockfile. Not only in one, but inside all the projects I tried opening.
And it also started happening a day after my computer crashed while working on the project. So there are these two events: Unity crashing and VPN.

So if somebody else ends up here:
For me it was a way too complicated OnDrawGizmo() Method i wrote in a Script.
The editor tried to draw the gizmo at start, took too many ressources so it crashed.
I commented the method out and it worked again. I also removed the import settings for the script, but im not sure thats a necessary step.

I got the same issue when my computer crashed while running Unity in Play Mode.
Deleting the Temp folder didn’t work for me, rather deleting the Library folder did the job.

Make sure your files are not marked as “Read Only.” I ran into this after downloading an old project that I unarchived from Collaborate, but it didn’t automatically set up properly. I had to move the files from the temporary “Collab” folder into the main project directory manually, and everything in the project was marked as Read-Only (obviously when using most source control, you will want that, but in this case it was just breaking everything).