Why Isn't Post Processing Working?

I’ve imported the post processing v2 from package manager, i also created a post process volume and tried to play with some of the settings but nothing was appearing, I tried adding Vignette and etc, I tried to find the issue but didn’t have much luck, one thing I did notice though was that if I went to project settings and quality, there was no render pipeline, do you think that is the issue? (Im creating a 2D game). Thanks in advance.

Post Processing with URP:

  • Use “Volume” not “Post-process Volume”
  • Delete Main Camera and create a new Camera without “Post-process Layer”, check “Post Processing” property.

Unity 2020.3 LTS

@mzk1198 A quick setup has to be done in order for you to start seeing the effects unfold onto your scene. A quick intro to what post processing is, its basically effects applied to your camera to improve the visuals of your game and therefore a camera setup has to be done before you can start using the post processing volume.

  1. On your main camera, click add component and search for a post process layer. This defines what layer to display your post processing effects on.

  2. Create an empty layer called ‘volume’ maybe and assign that layer to the object with your post process volume on.

  3. Then, in the inspector of the main camera, in the post process layer component, just set the layer to that new layer (layer called ‘volume’) you just created and assigned to your post process volume object.

And boom, youre ready to create a post process profile, attach it to your post process volume and begin brightening up your scene.

There are some great tutorials on all the effects you can achieve using the stack, as well as some demo scenes that people have set up in tutorials. I would recommend checking out Sketch (a Unity channel dedicated to terrain/level design) and see his tutorial on the post processing stack for a good idea of how powerful this tool really is. I hope that you get this working and send me any questions if you’re struggling to set this up.

So apparantly, you have to delete the old camera, and create a new one. Then when you add the post-processing layer, it will work.

Well I had the same issue. Find out that taking off the Render Pipeline from the Graphics in the Project Settings make it work. Ive also deleted the old camera and made a new main camera with the Post processing layer component. But I will need urp …So another problem now.

This has tripped me up so often (Unity 2019.4):
Make sure the Layer right at the top (above Transform) matches the Layer setting of the Post-Processing Layer. If they do not match nothing happens.

@Llama_w_2Ls I did this set up and it still didn’t work

There is no suck words to describe how unity hurts me, every year they doing some shit, and im feeling my ass burning like a rocket. Why? Why are they forcing me to use this new trash effects which are not working nometter how i try to make it work, i just want to use old easy and good post processing stack, but i cant!!! Where i can get old post processing stack with just BEHAVIOUR on main camera and effects profile? I just so angry on unity i cant describe, just want to drop this damn engine after so much time spend on it.


Just to elaborate for ppl finding this in 2022+.

This is only for those utilizing URP (Universal Render Pipeline)

Formerly LWRP (Light Weight Render Pipeline).

As other comments here have hinted; setting up post processing for

URP is a bit different than setting up PP for the standard render pipeline.

You can follow these 2 videos I found to be very useful:

However, it was still not working for me; nothing in the scene or game view

would change no matter what I did.

After many hours I found this:

Look for the URP renderer that you created when you first set up URP for your project.

If you used the default name it should be called “UniversalRenderPipelineAsset_Renderer” not to be confused with the the URP Asset “UniversalRenderPipelineAsset”

In the project view select the UniversalRenderPipelineAsset_Renderer.

Whilst selected, in the inspector, under the header: Post-processing

you will see a “tickable” box for enabled

make sure this is ticked.

also make sure you have a “PostProcessData” component referenced after Data (this one should’ve been set automatically by unity)

and if you were having my issue… viola! your Global Volume gameobject (if you are following the videos I linked above) will now accurately update both views with the post processing effect.

hope that helps someone.

Thank you for your help, but it turns out I had to delete the Post Processing volume and create a new one. Once I did that, I was able to get it working. Perhaps the best workaround for those having problems is to simply install Post Processing on SRP, delete the created PP Volume, create a new one, then proceed. There was also a PP Layer (in the Layers drop down) created when I installed the package. I deleted that, and created a new one. The problem may be involved in the way that the package installs. It all works if you manually create all components (PP Volume, PP Layer, and PP Layer Layer). Just a thought.

Solution for me at least was the following after around 2 hours of redoing the above steps.

The little button in the overrides / effect needs to be set to on, and it is very misleading, the on should be darker, that is when it is “really on”: 194177-on.png

Standard pipeline, 2020.3

Ticking “is global” on post process volume gameobject helped me to get post processing working with BRP

As a new game released in 2020 after two years Friday Night Funkin has become the best game of the rhythm music game genre. FNF game has an easy way to play, there are many levels to play and it is always updated with new levels.

Go to folder “Rendering” and select archive “Default_PipelineAsset_ForwardRenderer”… in inspector change “rendering path: deferred”